Photos and Images Not Loading?


We have been made aware that photos and images are not loading on the blog for some people. If you have having this problem please post your web browser version and operating system in the comments below (for example Safari 6.05, Mac or IE11, Windows 7). We are looking into it and trying to figure out the cause.


Steve Johnson

Founder and Dictator-In-Chief of TFB. A passionate gun owner, a shooting enthusiast and totally tacti-uncool. Favorite first date location: any gun range. Steve can be contacted here.


Advertisement

  • Stanislao

    Firefox 23 on Fedora 17. Will not show pictures if cookie permissions are set to block or session. Full cookie permissions required. Everything works fine on my bone-stock set-up of Chrome, which is why I have it.

    Problems did not appear until Cloudflare’s stuff was incorporated.

    • sauerquint

      Same observation here, Cloudflare is the culprit. Once I allowed them the images load fine. I use Adblock and Noscript in Firefox. So my browsing in pretty ‘safe’ in that I have to specifically allow something to show.

  • neoconfection

    Google Chrome, version 29 something. The pictures show in the text, but the photo albums never do.

  • Darin Henningsgard

    Loads fine in Canada.
    Unlike US export laws.

  • floppyscience

    Just started doing it to me today.

    Firefox 23.0
    Ubuntu 13.04

    I’m in Michigan, if that matters.

  • Moose Flavored

    Happening to me a bit recently. No pics for the last few days. Running Firefox Aurora 25.0a2 (August 30th 2013) on a Windows 7 ultimate PC

    • Moose Flavored

      In response to Stainislao’s comment, that might be the culprit, as I have cookie disabling addons installed and I also cannot see the pictures.

      • Steve (TFB Editor)

        Very strange. Am looking into it.

  • Ndlawyer

    iPad, iOS 6.1.3, Safari browser

  • vereceleritas

    Pictures have always loaded fine for me. I occasionally have to refresh the page to get the comments to load though.

    Firefox 23.0.1 on Windows Vista in Texas.

  • Geoff a well known Skeptic

    It was not working yesterday 31Aug13 it is working now. W7 with current updates (The latest ones are causing many problems) Mozilla Firefox 23.0.1
    Geoff
    Who notes Discus login stopped working a long time ago.

  • Anon154564198

    FireFox 23.0.1, Win 7 64-Bit

  • Callum King-Underwood

    Loads fine on chrome 29.0.1547.62 (with adblock) and Internet Explorer 10 (albeit hideously slowly) on windows 8 64 bit.

    Pictures do not load on internet explorer on windows phone 7, neither does discus which does load fine on a few other sites.

  • saiga556

    Images have been very slow lately.
    Chrome on Asus transformer tab running android.

  • Matthew Solis

    iOS 6.1.3, Safari, Iphone 4S. Just started in the last two weeks.

  • Suburban

    Over the last week, I couldn’t get pictures/images to load. Seems to be fine now. Currently running IE 7.0, because Chrome was crashing my computer, and I haven’t bothered to uninstall and reinstall yet.
    Windows 7
    Had to fix Compatibility View to allow posting comment.

  • Igor

    iPad, iOS 6.1.3, Chrome.

    The comment section also has problems.

  • anon

    I know you have to pay the bills, but there are so many add-ons and plug-ins on this website that it takes forever to load. And yes, I have high-speed internet.